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Hoole, Akustik für Fortgeschrittene, WiSe0809

Exercise with Praat. Acoustic analysis of fricatives using spectral moment measures

Log on to the matlab account.
cd to directory akustikfort/fricatives/cip’n’ (where ‘n’ is the number of your computer)

1. Preliminaries

Load each of the files
afa, asa, asha
ufu, usu, ushu

Use the editor to extract the fricative segment, and rename the new object in Praat’s object
list.
e.g afa ==> af

2. Basic script file

In the ‘Praat’ dropdown menu in the ‘Praat objects’ window choose ‘New Praat script’.
Enter the following in the new window (‘untitled script’)

mysound$="as"
select Sound 'mysound$'
To Spectrum... yes
Cepstral smoothing... 500
Rename... 'mysound$'_smooth
select Spectrum 'mysound$'
cog = Get centre of gravity... 2
std = Get standard deviation... 2
kurtosis = Get kurtosis... 2
skew = Get skewness... 2
printline 'mysound$''tab$''cog''tab$''std''tab$''kurtosis''tab$''skew'

With ‘File > Save as’ save the file with a name like fricative_script_1.txt

In the script window use the ‘Run’ command to execute these commands. If everything has
been typed correctly then in the object window you should see two new objects:
‘Spectrum as’ and ‘Spectrum as_smooth’
Also, the Praat info window should show a line of data consisting of the name of the sound
followed by 4 numeric values.

What does this script do?
Basically, it corresponds to the following interactive commands:

Select the sound ‘is’ then choose the command ‘Spectrum > To Spectrum’.
The resulting spectrum object is then smoothed with the command ‘cepstral

smoothing’ and renamed to distinguish it from the first spectrum.
Then the original unsmoothed spectrum is selected and a series of commands like

‘Query > Get centre of gravity’ is carried out.
The key feature of the script is that we use variables, so the whole series of commands can
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be applied very quickly to further sounds, and also the results can be printed in a more
convenient form.
mysound$ is a string variable (indicated by the final dollar sign) that for the initial example is
given the value ‘as’. Then, everywhere in the script where mysound$ appears in single quotes
its current value is inserted in the corresponding command.
All the ‘Get’ commands return their result in a numeric variable (cog, std, etc.). Then, with
the printline command we can print all the results at once in the info window. (Once again,
cog etc. in single quotes means that the current value of the variable is inserted. tab$ is a
predefined variable to separate each value with a tab).
This is much more convenient than the interactive ‘Query > Get’ procedure, since this just
prints one value at a time in the info window, and always overwrites the previous value.

3. Using Praat’s history mechanism

Normally, it is not necessary to write a script of this kind completely by hand.
To illustrate this, we will now figure out how to insert the overall intensity of the fricative (in
dB) into our list of results

First of all, in the script window move the cursor to the bottom of the window and choose the
command ‘Edit > Clear history’.

Then, in the object window select ‘Sound is’ and then ‘Query > Get intensity (dB)’
Make a note of the value that appear in the Info window.
Then, go back to the script window and choose ‘Edit > Paste history’
You will now see the commands that you need to use.
Figure out how to merge them with the rest of the script so that the dB value will be printed

as the first numeric value in the printline command (a total of 5 numeric values should
now be displayed).

Check that the script runs correctly, and that you get the same dB value that you previously
noted.

Check that the script runs correctly for other sounds.

4. Background to spectral moments

(See also the copy of the figure from Forrest et al., (1988), JASA 84)
These measures capture the shape of the spectrum using measures that are employed in
statistics to characterize a probability distribution.
The centre of gravity corresponds to the mean of the distribution. Intuitively, it corresponds

to the frequency that divides the spectrum into two halves such that the amount of
energy in the top half (higher frequencies) is equal to that in the bottom half (lower
frequencies).

Accordingly, standard deviation here captures the amount of dispersion of spectral energy
around the mean (i.e whether the energy is concentrated mainly in a small band or
spread out over a wide range of frequencies).

Skewness captures whether the distribution is tilted to the left or the right.
Kurtosis captures whether the shape deviates from that of a Gaussian distribution (basically,

whether it is more peaked or more flat).
Here are the explanations from Praat Help:
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 “The spectral centre of gravity is a measure for how high the frequencies in a
spectrum are on average. For a sine wave with a frequency of 377 Hz, the centre of
gravity is 377 Hz. You can easily check this in Praat by creating such a sine wave
(Create Sound from formula...), then converting it to a Spectrum (Sound: To
Spectrum...), then querying the mean frequency. For a white noise sampled at 22050
Hz, the centre of gravity is 5512.5 Hz, i.e. one half of the Nyquist frequency.

The standard deviation is a measure for how much the frequencies in a spectrum can
deviate from the centre of gravity. For a sine wave, the standard deviation is zero. For
a white noise, the standard deviation is the Nyquist frequency divided by %12.
(Note (Phil): For the above example of white noise sampled at 22050Hz this gives
3183Hz (=11025/3.4641))

The skewness is a measure for how much the shape of the spectrum below the centre
of gravity is different from the shape above the mean frequency. For a white noise,
the skewness is zero.

The kurtosis is a measure for how much the shape of the spectrum around the centre
of gravity is different from a Gaussian shape. For a white noise, the kurtosis is - 6/5.”

5. Phonetic Analysis

5.1 Fricative place of articulation
Analyze the different places of articulation, keeping vowel context constant
i.e analyze in the order afa, asa asha, then ufu, usu ushu

When you have a complete set of analysis results in the Info window, store it to a text file
named something like fricative_poa.txt

5.2 Effect of coarticulation
Analyze in the order afa, ufu, then asa, usu, then asha, ushu

When you have a complete set of analysis results in the Info window, store it to a text file
named something like fricative_coarticulation.txt

When doing the coarticulation analysis try and note cases where coarticulation may make
differences between place of articulation less obvious.

6. Visualizing the spectra

If desired, try and merge this step with step 5.

For each group of analyses plot the smoothed version of the spectrum in the picture window
using the draw command.
e.g overlay overlay all places of articulation in /a/ context etc.

overlay /f/ in both vowel contexts etc.

Use the picture window pen command to choose a different colour for each fricative in the
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plot (before starting use the pen command to set line width to 2).
Important: It will necessary to try out first what will be appropriate values for minimum
power and maximum power in the draw command that can be used for ALL fricatives (and
then keep these values the same every time the drawing command is used).

If at all possible, use the history mechanism to insert appropriate commands in the script.

When each picture is complete use the ‘Margins > Text top’ command to insert some text
explaining what colour is used for what fricative
Save the picture as an eps file

7. Listening (mainly for fun)

Concatenate the fricative segments to a single sound, grouped first by place of articulation
and then by vowel context.
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FIG. !. (a) Two spectra that differ in mean and skewhess. The thin-lined 
spectrum has a mean of 1.0 kHz and a positive skewhess of 4.0. By contrast, 
the thick-lined spectrum has a mean of 4.5 kHz and a slight negative skew- 
ness of -- 1.2. (b) Two spectra with similar means and skewhess, but differ- 
ent kurtoses. The thin-lined spectrum has a kurtosis of -- 0.7, which is re- 
flective of its diffuse peaks, while the thick-lined spectrum has a kurtosis of 
6.7. All spectra were LPC smoothed for easier viewing. 

where the frequencyfk of the k th frequency sample is given 
by fk =f•k/SI2, where • is the sampling frequency at 
which the speech waveform is acquired. The moment Li has 
the units of frequency to the ith power. Dimensionless ver- 
sions of the third and fourth moments are computed accord- 
ing to/_• = L3/(L 2) 312, where 13 is the coefficient ofskewness 
and 14 = [L4/(L2) -• ] -- 3, where 14 is the coefficient of kur- 
tosis (see Newell and Hancock, 1984). These dimensionless 
versions of the third and fourth moments are normalized 

with respect to shifts in center frequency and frequency scale 
that can occur between subjects producing the same sound. 
Examples of spectra with different values for each of these 
moments are presented in Fig. 1. 

Bark transform frequency scale moments were comput- 
ed from the power spectrum using a somewhat different pro- 
cedure from the one used for the linear frequency scale mo- 
ments. The Bark transform is a nonlinear warping of the 
frequency scale performed according to formulas stated by 
Syrdal and Gopal (1986). This FFT algorithm computes the 
Fourier spectrum at the uniformly spaced frequency sam- 
ples fk- If we apply the Bark transform to the frequency 
scale, the corresponding Bark samples b& will be nonuni- 
formly spaced. The Bark moments were computed using the 
procedure outlined for the linear moments, where we re- 
placed the power spectrum P(k) with the weighted power 
spectrum (bk -- bk_ 1 )P(k) and we replaced the frequency 

samplesfk with their corresponding Bark samples b&. In this 
manner, nonuniform spacing of spectrum values on the Bark 
scale gave more weight over the region where the Bark scale 
was more sparsely sampled. 

The moments data from each subject were grouped 
across all repetitions of each target obstruent, independent 
of the vowel context. Moments calculated for each obstruent 

were then grouped according to the time interval from which 
they were derived. For example, all moments calculated 
from the first 10-ms interval for all repetitions of one sub- 
ject's production of/k/, were grouped; a similar grouping 
was made for the next 10-ms interval, etc. The data from all 
subjects of a given gender were then combined. 

Though the first four moments were calculated, it was 
determined that the second moment, the variance, did not 
add to the discriminability of the different obstruents, so it 
was not used as a discrete variable in our analyses. The effi- 
cacy of the remaining moments in differentiating place of 
articulation was evaluated by means of graphic representa- 
tion and discriminant analyses. 

Stepwise discriminant analyses (BMDP7M) were per- 
formed separately on the stops and fricatives. Basically, the 
discrimant analysis is a linear combination of"n" variables 
such that the resulting functions, or canonical variates, pro- 
vide maximum distance between members of different cate- 

gories while minimizing the distance between members of 
like categories. The number of canonical variates is depen- 
dent on the number of categories to which the data are to be 
assigned; there is one less canonical variate than the number 
of categories. Discriminant analysis is very sensitive to de- 
viations of the input variables from normality. For this rea- 
son, a Shapiro-Wilk (Shapiro and Wilk, 1965) test of nor- 
mality was performed on all input-variable distributions. All 
variables were normally distributed (p > 0.05). 

D. Results 

The moments data were used to construct three-dimen- 

sional graphs for each target place of articulation. The time 
interval (re: obstruent onset) from which the moments were 
calculated was used as a parameter. In this way, four rel- 
evant dimensions (mean, skewhess, kurtosis, time) could be 
displayed in three-dimensional space. Figure 2 presents rep- 
resentative graphs from one subject for the linear moments 
calculated from the first 10 ms (burst to burst + I0 ms) of 
each voiceless stop. The data are collapsed across all vowels, 
as are all data presented in this article. 

It can be seen in Fig. 2 that the simultaneous evaluation 
of mean, skewness, and kurtosis differentiates the place of 
stop articulation. For example,/p/and/t/differ consistent- 
ly in skewhess and mean but not in kurtosis;/k/is similar to 
/p/in mean and skewness but differs from the other places 
of articulation in kurtosis. The graphic representation of the 
linear moments suggests that labial and alveolar stops are 
distinct in terms of mean and skewness, while the velar stops 
are distinguished by their kurtosis. 

Figure 3 presents the Bark moments for the same time 
interval and subject as the linear moments presented above. 
As with the linear moments, differences can be seen in the 

three-dimensional space occupied by each place of articula- 
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